Burning oil smell. - Saturn Outlook Online Community
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 07-11-2016, 12:17 AM Thread Starter
SR
Junior Member
 
Join Date: Jun 2015
Posts: 25
Burning oil smell.

Over the last several weeks I've started noticing an oil burning smell coming from the car, particularly when going uphill. I haven't seen any obvious cause, no oil along the botyom of the power train, no oil drips on my driveway, etc. Almost smells more like gear oil than motor oil, but def has that burning smell.

Also, just in tne last couple weeks, a P0420 error code has been setting. Scanner says "Catalyst System Efficiency Below Threshold (Bank 1).

Could the two be related?
SR is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Saturn Outlook Online Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome