07 Outlook issue - Saturn Outlook Online Community
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 11-11-2017, 11:21 AM Thread Starter
Junior Member
 
Join Date: Nov 2017
Posts: 3
07 Outlook issue

Ok have an 07 Outlook. This last Tuesday went out to start it and it would click and everything would true off. Was told battery. After replacing the battery, we tested the old one and it was indeed bad. But after replacing the battery the car literally won't do anything. Put key in and try to start and all it does is hum. Says park assist off and the vehicle is in park. The gauges don't move and my key gets stuck. I did figure out how to get the key out but as for everything else no idea why my car won't run. Any tips and idea would be appreciated. Thank you
Ishymay88 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Saturn Outlook Online Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome