Saturn Outlook Forum banner

I need help to figure out what is wrong please -2007 Traction Off service stabiltrak system

  • traction control off

    Votes: 0 0.0%
  • stabiltrak system

    Votes: 0 0.0%

  • Total voters
    0
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 2007 Saturn outlook with about 73000 miles.

In 2014 my car basically lived at the dealer for 9 months while they tried to find the reason for the interior of the car to get soaking wet every time it rained. Finally it was fixed in November of 2014. GM covered all rentals and labor due to a sunroof recall in 2008 which they worked on. It turned out to be a predrilled factory hole that was not used - this was found after moonroof and sunroof replacements and seals repaired then replaced. Long time, but GM staff were friendly and it was a pain, but free! Water had been getting in dashboard, I had to fix heater blower due to water damage.

Recently, November 2015, I drove in the rain and the power steering flaked out. I had to manhandle the car to a parking lot, within a few minutes the power steering was back. I got home only after while driving down the straight road it happened again, but came back before I had to pull over. Since then it has happened twice more in the rain. I have not had it serviced for this rain issue.

Now...
In January 2016 the traction off sign came on the dashboard. Also, another message has been added, service stabiltrak system. It went off the other day and now it's back complete with beeping. The car seems to be running alright. When I backed up from a parking space through ice it spun, it was a very small puddle of ice. Not sure if that means the traction was on or off... It was confusing to spin at such a slow speed on such a little puddle.

Any ideas? Any recalls? I'm planning a 1200 mile roundtrip to Maine in 3 weeks- Winter!!!.
 

·
Registered
Joined
·
754 Posts
there was a service bulletin on the early models.
In rainy weather, water would be splashed onto the serpentine belt and the belt/pulley would slip- causing the momentary loss of power steering.
I believe the fix was the addition of a splash guard/shield.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
rbarrios said:
there was a service bulletin on the early models.
In rainy weather, water would be splashed onto the serpentine belt and the belt/pulley would slip- causing the momentary loss of power steering.
I believe the fix was the addition of a splash guard/shield.
thank you so much! I will call GM and ask tomorrow. Any ideas about the service stabilitrak or traction off signs would also be really helpful.
 

·
Registered
Joined
·
754 Posts
the traction messages- are a little more tricky--- MANY items can cause those messages to come up.
for example- right now with cold weather---
many folks are getting that message if its very cold outside- and their throttle bodies are dirty.
with the cold air- moisture in the tube/throttle body- is freezing- causing the CEL to come on, engine reduced power, stabilitrack etc.

Manye times they pull over- shut off engine for 5 min, engine heat melts the ice-- and off they go...

but youd have to check if any codes were set---
 

·
Registered
Joined
·
13 Posts
Mine started this yesterday. The Tranny is making a weird gridding noise at low speed 1st - 3rd gear. Then in Park, as I rev it up it makes weird noises from the tranny area. I was thinking it my be the torque converter. For the last 3 year, when I put the car in drive, it took about 2-3 seconds for it to engage, but now it goes right into gear... weird... Any Thoughts
 

·
Registered
Joined
·
13 Posts
I was way off the problem... The Engine Oil Level can also cause the Traction Control and Stabiltrak Light to come on. I just check the Oil last month, so didn't think anything about it, but it was 4 qts. low... I know, I know... My fault... Going to do a oil change tomorrow, but got the level where it needs to be and everything is feel. I think it burning the oil cause I couldn't find a leak.
 

·
Registered
Joined
·
203 Posts
Four quarts low and you didn't get a message about low oil pressure? You should check the oil pressure switch. Also check where the oil is going, you probably aren't burning it. Check the air intake snorkel between the air filter and the throttle body to see if you have excessive oil pools in there, and a dirty throttle plate.
 

·
Registered
Joined
·
13 Posts
Girlfriend has been driving, so I had no idea what has been going on with her car. I have been meaning to change the oil and final got around to do it. Got under the Outlook to break the bolt loose and saw that there was oil all down the underbody. Got up top and went to take the filter off and that little son of a gun was loose. This is the reason I got have shops change my oil.
 
1 - 9 of 9 Posts
Top