Saturn Outlook Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Our 2008 Outlook has 3,000 miles on it and has started surging when it is under a load. It is worse when it is in a lower gear and on a hill. Not sure if the problem is in the motor or transmission. I plan on calling the dealer tomorrow. I was curious if anyone else is having the same problem.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
No, it is not at idle. The only time it is noticable is when you are accelerating from a stop, especially if you are going up hill (under more load). I have not towed with it but I am sure it would be worse.
 

·
Registered
Joined
·
12 Posts
You need the new trany update...I had the same problems with mine...It almost felt like sometimes I had mud on my tires...Wierd shifting patterns..like it wasnt sure when to shift.. I got a flyer in the mail this month saying the Saturn Had a NEW engine and trany software update..I took it in and WOW it is a different machine..I cant tell you enough how much difference I feel in the overall performance and fuel economy now...
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
With ours being manufactured in September I thought it would have the latest update. I am scheduled to take it in tomorrow.
 

·
Registered
Joined
·
34 Posts
tncamp said:
With ours being manufactured in September I thought it would have the latest update. I am scheduled to take it in tomorrow.
Please let us know what they find and whether they needed to apply the latest update... I also have an '08 that was manufactured in September and I assumed I did not need the update, but my XE does surge heavily going up inclines (it is pretty hilly here in Southern PA).
 

·
Registered
Joined
·
24 Posts
My XE was "born" on 10/12. It also feels quite choppy in shifting. I don't have it broken in yet, but I sure hope it gets better. If this is the new update, they still have some work to do!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
I took it in and it has the latest update. Just as I predicted it was acting fine on the day I took it in. They did not have an answer, just asked me to stop in anytime it was doing it and take them for a test drive. Let me know if any of you get yours fixed.
 
1 - 8 of 8 Posts
Top