Saturn Outlook Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
yikes !!!!

this vehicle has lots of gemmins. love it when it is running but hate it when it starts the engine code lite.

very difficult to diagnose and fix. many hours on service tracton control, stabilitrak. this alert can mean almost anything and is random. shame on you gm.

too complex and very subject to mechanical troubles. this vehicle will cost you $$ to keep running.

do not buy it.
sincerely,
charlie p.
aircraft a & p licensed mechanic. not fool.
 

·
Registered
Joined
·
5 Posts
We are on our 7th Saturn . Have had S1,S2, L200 ,Vue Redline and now a 2008 Outlook. We drive them till the sub frame rust out. All have been very good cars for us and not a lot of issues other then regular maintenance. I do all my own work, the outlook I bought at a good price as it had high miles on it. I knew the motor had issues. The outlook was in very good condition so I put a new GM motor back in it. It had the normal traction, and stabilatrack codes. I seached and tried many things. It needed tires and alignment as I had the sub frame out to put the motor in. My code reader did mention alignment. So belive it or not. After the new tires and alignment the traction control and stabilatrack issues are gone. All I have left is service airbag message.
 

·
Registered
Joined
·
203 Posts
Your service airbag may be a loose connection on the under seat connector. There were a couple special service bulletins, first to re-secure the connector, then another to replace it with a soldered splice. If you do it yourself make sure to disconnect the battery and leave it off for 10 minutes before disconnecting the connector. Getting to it is easy after you remove the seat bolts and flip the seat back. i only did my passenger seat. Make sure you read the bulletin and use a butane soldering iron, not electric, the bag may deploy with an electric one,
 

·
Registered
Joined
·
1 Posts
We are on our 7th Saturn . Have had S1,S2, L200 ,Vue Redline and now a 2008 Outlook. We drive them till the sub frame rust out. All have been very good cars for us and not a lot of issues other then regular maintenance. I do all my own work, the outlook I bought at a good price as it had high miles on it. I knew the motor had issues. The outlook was in very good condition so I put a new GM motor back in it. It had the normal traction, and stabilatrack codes. I seached and tried many things. It needed tires and alignment as I had the sub frame out to put the motor in. My code reader did mention alignment. So belive it or not. After the new tires and alignment the traction control and stabilatrack issues are gone. All I have left is service airbag message.
I am in the same position as you were. Purchased a Saturn Outlook XR 2007 at a very good price. Inside is perfect shape for the year, however, after driving it for about a month I started getting the same codes, Service Stabilatrack, Service Traction Control, All Wheel Drive Off. Now only the from wheels are getting power. This is a heavy vehicle and the from wheel power is not enough. Pulling out of my driveway is a bit of a challenge. Driving in the rain is scary and I try to avoid it if possible. So I would like to ask your advice. Oh, I almost forgot, The codes also said the front right and back left wheel speed sensors were bad. I replaced both but still having the same issue. Any ideas that I can try?? I'm so frustrated and out of options to try. Thank you in advance for your help.
 
1 - 4 of 4 Posts
Top