Saturn Outlook Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My 2008 Outlook has recently started shifting from Reverse to Drive slowly. When I back up and then shift to Drive, I have to wait about 3 seconds for it to shift from Reverse to Drive. Any thoughts on what would cause this?
I had the 3 5 Reverse wave plate replaced about 18 months ago. (I don't know if thats at all related but wanted to mention it since its a common issue.)
 

·
Registered
Joined
·
214 Posts
Could be the TEHCM which has pressure switches and solids inside. Some owner's have reported a failure of the module because of contaminates plugging the screens or valves. Many were reported to have failed after the wave plate replacement when the system may not have been flushed properly to remove all pieces of a broken wave plate. Here is what it looks like, and note what it says about failure of the unit.

http://www.dormanproducts.com/digitalassets/document/TransmissionControlModule_DOR.PDF
 

·
Registered
Joined
·
13 Posts
What's the pricing on those?
 

·
Registered
Joined
·
4 Posts
Our 2008 is doing this same thing as well. I am afraid the wave plate is gone causing this as well. No help from GM yet. I am hearing that 2nd owners aren't getting much help as well... good luck!
 

·
Premium Member
Joined
·
458 Posts
stevenriz1 said:
Our 2008 is doing this same thing as well. I am afraid the wave plate is gone causing this as well. No help from GM yet. I am hearing that 2nd owners aren't getting much help as well... good luck!
The 10 year 120,000 coverage for the wave plate goes WITH the vehicle. Have you contacted a dealer yet?

Additional note, if it is NOT a wave plate failure of course they won't cover it IF out of warranty and yours would be in that instance.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top