Saturn Outlook Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2009 ssturn outlook xe awd. I replaced the coils and plugs. Took it for a drive, everything ram and sounded good. The next morning after I left for work my wife went out to the car and heard what sounded like a fan running under the car near where the gas tank is. The only way to turn it off is to disconnect the battery. It still runs fine while driving, but the fuel pump keeps running. It also stops if you pull the fscm fuse. Ive had people tell me its the relay, but I cant find what relay it would ne. Any thoughts?
 

·
Registered
Joined
·
203 Posts
I searched for a relay in the service manual but I cannot find it. If you search the forums, Acadia, Enclave and Traverse, there may be a link to download the manual. There are some posts where water leaks have contributed to the ignition staying on, I believe there is even a TSB on it. Did you have any water leaks? Water can do a number on the electronics in these vehicles.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
The vehicle had been in the garage for over a week before I took it out, and the day I took it out was a dry one. Im not aware of any water damage, though Ive seen similar posts warning of it. Ive downloaded a service manual, but also could not find where the relay might be. There is a fuel system control module on the back of the fuel tank, but it just seems like there should be a relay regulating the electricity before that.
 

·
Registered
Joined
·
203 Posts
You actually have two fuel pumps. One in the tank and a high pressure pump on the engine. That module is there by the tank? I don't think you would have a relay with that, it gets the command right from the computer. If you suspect that as the problem and replace it, it will need to be programmed. Maybe yours need re-programming.
 
1 - 4 of 4 Posts
Top