Saturn Outlook Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hey all just wanted to find out if anyone had replaced their factory stereo? I am looking to put in a pioneer x910bt into the outlook we just bought. Any tips? I am pretty sure I have all of the connectors ordered that I will need to keep the steering wheel controls and onstar. If anyone has done this in an 09 and had any issues or things to avoid let me know otherwise I will post how it goes and if everything works when I am done.
 

·
Registered
Joined
·
1,093 Posts
:welcome:

I think you would be the 1st to do that in an 09' XE. Are you going to do the work yourself? Be careful taking off the bezel, like using a trim removal too and a soft cloth, you dont want to crack it or break a tab. Is the unit your wanting to install a Nav unit? Post pic's of the install if you can :).
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Yes I will be doing the work myself. I will be careful have installed a new radio in every car I have owned so far but each car is different and think this will be the hardest due to all the extra stuff to tie into it onstar and safety chimes but hopefully it will all turn out ok. Will take pictures as I can during the install. Yeah it is a nav/dvd/touchscreen with voice control and bluetooth built in. not sure if the car is going to like the bluetooth in the radio as i believe the bluetooth it has now runs more through the onstar and just uses the radio for speakers. we will see. I will let you all know how it goes. Thanks, for the welcome by the way. :blob:
 

·
Premium Member
Joined
·
297 Posts
Welcome to the board and good luck. Go ahead and update your signature with all of your vehicle info and the mods you are doing so that when you post in other topics all will know what you have.

:cheers: :welcome:
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
Just a little update almost everything for the new stereo has been shipped can't wait to get it the wife is really looking forward to the Ipod controls on the stereo and hopefully the voice commands work on this thing. Will post pictures of everything when it arrives.
 

·
Registered
Joined
·
1,093 Posts
takeo81 said:
Just a little update almost everything for the new stereo has been shipped can't wait to get it the wife is really looking forward to the Ipod controls on the stereo and hopefully the voice commands work on this thing. Will post pictures of everything when it arrives.
You better post pic's, I'm excited :D ;D. Good luck.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
Just got all of the parts in for the stereo upgrade. Going to start working on the wiring tonight. :confused:
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
Got the stereo installed tonight and it works great only problem is the steering wheel controls don't work since I can't get the pac swi to program. I am working on getting the problem resolved but here are some pictures. FYI not alot of room around the radio for anything.IMG]http://i830.photobucket.com/albums/zz227/takeo81/IMG_0193.jpg[/IMG]
 

·
Registered
Joined
·
1,093 Posts
It looks like a great set- up :thumb:. Do you think that the pac swi unit is bad or the wrong one for your OUTLOOK? Hope you get it working :). How about a speaker swap?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #10
Not sure it is the right unit I email PAC tech support last night. Didn't swap any speakers maybe in the future but that is more of a pain then the radio swap in my opinion. I mainly wanted the nav and ipod control.
 

·
Registered
Joined
·
2 Posts
Looks like a nice system! What brand-part# is you install kit? mine dose not fit that good. I have the kenwood 5120 and I love it.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #12
Thanks, the dash kit Metra 95-3305. Got it on amazon for $13 plus shipping.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #14
Not yet havn't had time to work on it was busy at work. Going to try and get it fixed this week.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #15
Just a little update. Talked to tech support at PAC for the steering wheel control issues I am having and they said that if you are using the GMOS-LAN-01 you have to put a relay in to give it power as the GMOS module will sometimes prevent the PAC - SWI from staying in programing mode. They said have Accessory power trigger a relay to feed constant power to the power wire of the PAC-SWI. Kinda pissed about that cause of the mess of wires I already have. I ordered the Axxess Steering wheel interface to try it before trying to hack a relay in will let you know how it all comes out.
 

·
Registered
Joined
·
1,093 Posts
Do you have to pull the unit out again to get to where you have to be for the relay?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #17
Yeah I have to pull it all out no matter which way I go with it. Also if anyone else does this be sure to Delete any phones you have paired to your factory bluetooth. I didn't and my phone would pop up with connect to GM constantly when in the car. If you don't delete them first you have to reattach the steering wheel control wire back to the original location and put the old stereo back in to get them deleted. Learned that this week too. :banghead:
 

·
Registered
Joined
·
1,093 Posts
takeo81 said:
Yeah I have to pull it all out no matter which way I go with it. Also if anyone else does this be sure to Delete any phones you have paired to your factory bluetooth. I didn't and my phone would pop up with connect to GM constantly when in the car. If you don't delete them first you have to reattach the steering wheel control wire back to the original location and put the old stereo back in to get them deleted. Learned that this week too. :banghead:
Man that sucks, well at least you know what to do now and it should be a snap to do, I hope :-\. Good luck and keep us posted when you get it all working :).
 

·
Registered
Joined
·
4 Posts
Hello,
I am so happy to find this post. I have a 09 traverse that I am planning to do they same thing. I have so many questions for you. I am planning to get the avic z110bt. I am also adding a overhead dvd player that I will send a Video out and in from pioneer deck. I am also going to run a rearview cam. I have the one in the rear view mirror, but probally wont be able to get the feed to send to pioneer. If you dont mind, I have some questions about the install to ask. Also, I considered the 910bt instead of the z110bt, how do you like the 910? Do you think it would be worth upgrading to z110? only about $300 different in price.
Thanks,
Bryanb
 

·
Registered
Joined
·
15 Posts
Discussion Starter #20
I like the 910 the boot up time is a bit slow but it is running on Windows so go figure that it is slow. I don't know much about the Z110 I do know that the software on the Z110 isn't able to be modified the way the 910 is so when I plan changing some things I will be able to. You will get a bigger screen with the Z110. Any questions you have ask away and I will try and answer to the best of my ability sounds like you have big install plans going on.
 
1 - 20 of 27 Posts
Top