Saturn Outlook Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hello all, I have an 09 Outlook XR AWD with the 20's. When I first bought it I was in Utah and could use the AWD. Now I am in Texas and the AWD is useless. But I really love the vehicle. Anways, in the past few months, I have begun to hear clicking noises in the left front. Especially if sharply turned, like pulling into and out of parking garages. Never here is if going straight. If I turn the wheel, even a little and have to accelerate at a quicker than normal rate, like merging into traffic from a side street, it clicks there as well. Also if changing directions from forward, stop and then reverse it clicks again. Is this the CV joint or something else that I dont know about? Thanks for your time.
 

·
Premium Member
Joined
·
458 Posts

·
Registered
Joined
·
214 Posts
The way you have described your clicking noise, I would have the CV joints checked, along with the rest of the drive axle components. Yours sounds more like a drive line issue instead of a steering rack issue. Check for any torn boots which may have allowed the grease to leak out also.
 

·
Premium Member
Joined
·
458 Posts
:thumb: That is a good idea as well.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Mine does do that whirring sound with the sterring wheel too, but the problem I was asking about is probably more along the lines of what ls973800 replied. Lovely. Good thing I bought the extended warranty when I bought it used. Now the hard part, getting it to the shop. :)
 

·
Registered
Joined
·
353 Posts
cna91 said:
Mine does do that whirring sound with the sterring wheel too, but the problem I was asking about is probably more along the lines of what ls973800 replied. Lovely. Good thing I bought the extended warranty when I bought it used. Now the hard part, getting it to the shop. :)
If you need assistance with setting up an appointment please, let me know.

Michelle, GM Customer Service
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
GM Customer Service said:
If you need assistance with setting up an appointment please, let me know.

Michelle, GM Customer Service
Michelle, I sent you a PM, not sure if it went through though. I put the code in and hit send and it went away and I dont see it in the outbox or anything, Thanks, Aaron
 

·
Premium Member
Joined
·
458 Posts
cna91 said:
Michelle, I sent you a PM, not sure if it went through though. I put the code in and hit send and it went away and I dont see it in the outbox or anything, Thanks, Aaron
Go to your profile and then click on "personal messages option" then see if you have this "check marked in the box": Save a copy of each Personal Message in my outbox by default.

If not then your messages will not be saved.
 

·
Registered
Joined
·
353 Posts
Sailfish said:
Go to your profile and then click on "personal messages option" then see if you have this "check marked in the box": Save a copy of each Personal Message in my outbox by default.

If not then your messages will not be saved.
Thank you for assisting cna91 with this. You are the bomb! LOL

Michelle, GM Customer Service
 

·
Premium Member
Joined
·
458 Posts
GM Customer Service said:
Thank you for assisting cna91 with this. You are the bomb! LOL

Michelle, GM Customer Service
;D ;)
 
1 - 10 of 10 Posts
Top