Saturn Outlook Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Anyone done a knock sensor...trying to find an illustration or at least get a rough idea of where it might be. Obviously it's on the block somewhere, but not sure if it is front or rear.
Thanks,
Ryan
 

·
Registered
Joined
·
214 Posts
Looks like there are two of them, one each on each cylinder bank. Bank one needs the lower manifold heat shield removed to access it. It is part number 2 with the harness number 1. Bank 2 says to remove the negative battery cable and then the oil filter to remove the sensor.

Sorry, I can't get the diagram to post using the attachment feature.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thanks, that'll work fine. Now I need to check with the dealer and see which one was acting up. I think they said there was a wiring harness I should replace as well. Given their estimate of $3-400 labor, sounds like it must have been the bank 1 sensor. I appreciate it...
 

·
Registered
Joined
·
214 Posts
Good luck and let us know if you ended up doing the repair. Both sensors have a wire harness so I really don't know if you can say for sure which one is bad without testing them.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I'll be doing it for sure but I am about to put a two post lift in the garage so I'll probably wait until that is done. It's an intermittent CEL so not a huge hurry.

Unfortunately I need to fix the pinion on my Jeep first...it's a little higher priority. Sounds like a hamster wheel.

I'll update with pics when I do the sensors.
 
1 - 5 of 5 Posts
Top