Saturn Outlook Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey Guys

Im new here. Ive used the search function and gone through every page of your forums looking for anyone who has the same problem as me, and I couldnt find it, so I am hoping someone else can point me in the right direction.

2009 Saturn Outlook XR AWD 3.6L 98k miles. About 1000 miles ago I was getting a cylinder 5 misfire, so I replaced all of the Spark Plugs and Coil Packs and everything in that area. Car went back to running great. About 2 days ago, I was coming out of a red light and all of the sudden the engine got loud like I had an exhaust leak and it had no power. I could not rev over 4000 RPM and couldnt get moving faster than 40-45mph. I pulled over and looked around the car. I had a warning on the dash that says service stabilitrack and an CEL P0101 for a faulty Mass Air Flow Sensor. I replaced the MAF and everything was fine for less than a day or so.

Now, the car dies any time I hit the gas pedal for anything. It will start and warm up and idle fine, but pressing the gas pedal, even a little bit makes it bog down and die. It doesnt even have to be in gear. It will do it from park. But if I hit the gas to rev, the car bogs down and dies. I thought it might be a faulty Throttle position sensor, so I purchased an entirely new throttle body and sensor unit and installed it all, but its still doing the same thing. No new engine codes are being given.

This is my daily driver and I need it to be able to get back and forth to work.

Maybe fuel pump? or clogged fuel filter? I honestly have no clue, but Im $300 bucks in at this point and have a vehicle I cant drive.

Any ideas would be greatly appreciated.
 

·
Registered
Joined
·
203 Posts
You may have clogged a cat when it was missing since you were running rich. Also there isn't a lot of activity on this forum lately, try one of the others, Enclave,Traverse and Acadia for more input.
 

·
Registered
Joined
·
203 Posts
The jury is out whether you can clean a clogged cat, most replies state that you can clean a dirty one but cannot clear out a clogged one.
Take these with a grain of salt.
search the other forums too.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Cats arent clogged. Good exhaust coming from both tail pipes. I heard a constant clicking coming from the Evap solenoid cannister by the throttle body so I spent 50 bucks and replaced that. It seemed to improve the issues a little bit, but im still having issues accelerating. I took it around the block at my apartment complex and it didnt die, but it didnt want to go. Throttle was very jerky. Im wondering if the car is in limp mode? Maybe I can get it reset?
 

·
Registered
Joined
·
203 Posts
Try it, disconnect the battery for 20 minutes and then re connect it and bring her back to life. if it were in limp mode the display should state it.
How about the throttle body, nice and free and clean? Air filter clean?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
I ended up taking it to a shop for a good diagnosis. He said the cats were completely stopped up. Even tho the check engine light isnt on.

I purchased the cats to replace the bad ones but I'm having trouble finding instructions on how to do it. I'm sure it's just plug and play but the bolts are in very hard to reach locations.
 
1 - 7 of 7 Posts
Top