Saturn Outlook Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
our 07 hit 100k miles so I changed the plugs found 2 where the coils had oil on them. sucked out the oil and changed the plugs. Ran great started quick up to 23 mpg (averaged 21 before) A week later checked oil half a quart low. week later whole quart low 3 weeks later again a quart low. Didnt see it burning at all. Anyone else have this issue??
 

·
Registered
Joined
·
142 Posts
My 08' has used about a half of a quart per thousand miles since it was new. I have no idea why it does it. No leaks and no smoke.
Tim C.
 

·
Registered
Joined
·
63 Posts
Look inside the intake tube where the crank case vent goes back into the intake. Its always oil in there, don't know why but I have to clean it out every oil change....
 

·
Registered
Joined
·
203 Posts
It really isn't normal to have this oil in there. This condition has caused my outlook to have stabilitrack disabled, service stabilitrack, service traction control messages, which I call the trio of messages. This is caused by a Mass Air Flow sensor going bad due to the oil and moisture in the Air Intake snorkel. This winter has been especially bad and my throttle body has froze up on me with all that moisture.
A guy on one of the Camaro forum websites has found the culprit and posted a solution. Here is the link.

http://www.moderncamaro.com/forum/v6-engine-discussion/53385-llt-lfx-pcv-orfice-mod-importance.html

I did this modification last week and I have had only a few drops of oil and moisture since. The PVC orifice barb on the Lambda's is on the drivers side down by the firewall. Good Luck.
 
1 - 4 of 4 Posts
Top