Saturn Outlook Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi all,
My 3 power outlets inside the cabin stop working. As the one located in the trunk still works , it made me wonder if this was only due to a burn fuse. I put a new fuse (25A) yesterday but they still don't work.
Has anybody experieced the same issue? Any recomendation?

Cheers
Paul
2008 Outlook XE
 

·
Registered
Joined
·
754 Posts
did it blow that fuse right away?
 

·
Registered
Joined
·
754 Posts
This was the fuse in the engine compartment fuse box correct?
(theres a 2ns fuse box in the passenger compartment).
 

·
Registered
Joined
·
17 Posts
paulotuco said:
Hi all,
My 3 power outlets inside the cabin stop working. As the one located in the trunk still works , it made me wonder if this was only due to a burn fuse. I put a new fuse (25A) yesterday but they still don't work.
Has anybody experieced the same issue? Any recomendation?

Cheers
Paul
2008 Outlook XE
I don't know if this might resolve problem or not but according to the service manual the fuse that supplies the 3 outlets inside the cabin is a 20A fuse and is located in the underhood fuse block and labeled AUX PWR. Another 20A fuse labeled RR APO supplies power to the rear outlet.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
Thank you, I thought it was the 25A fuse named power outlet (PWR OUTLET), I will try and replace this one and will post the results.

Cheers
Paul
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
Hi Outlookowner,
You were right, the blown fuse was the 20A AUX PWR,, I replaced it yesterday and all outlets are now back to work.

Thank you

Paul
 

·
Registered
Joined
·
754 Posts
Did you figure out what blew it?
 

·
Registered
Joined
·
353 Posts
@paulotuco, I am glad to read that you have this taken care of. The members of this community are awesome in helping.

I hope that you have a great weekend.

Michelle, GM Customer Service
 
1 - 9 of 9 Posts
Top