Saturn Outlook Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
the dealership said i needed to replace the power steering pump @ $435 .. bought the part @ Autozone for aprox $70 and replaced it today. It did not fix the problem. Steering is very hard at low speeds when turning only .. as into a parking space. On the road at higher speeds there is not a problem. The dealership said he was SURE that was the problem. ?? now what?
 

·
Registered
Joined
·
252 Posts
Could also be the steering rack. Maybe you would find better information by searching the other lambda forums (links are on the main page).
 

·
Registered
Joined
·
1,093 Posts
I just had the steering rack and pump replaced on my '09 under warranty. The steering system is VERY hard to bleed and you have to have a special tool to do it correctly according to the tech and it takes over an hour to do. He was not impressed on how they designed this system to bleed. Matter of fact I think they let mine sit overnight to help bleed the air out and did the allignment in the moring.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
grnmax7 said:
the dealership said i needed to replace the power steering pump @ $435 .. bought the part @ Autozone for aprox $70 and replaced it today. It did not fix the problem. Steering is very hard at low speeds when turning only .. as into a parking space. On the road at higher speeds there is not a problem. The dealership said he was SURE that was the problem. ?? now what?
[what was under warranty ?? .. my dealership said it was not under warranty
 

·
Registered
Joined
·
754 Posts
are past 100K? or 5 yrs?
 

·
Registered
Joined
·
1,093 Posts
I'm still under B2B, my steering rack and PS pump was replaced under warranty.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
6Sixathome said:
I'm still under B2B, my steering rack and PS pump was replaced under warranty.
I don't know what 'B2B' is .. Yes, I'm under 100k .. and less than 5 year -- 88,000 and 5 year in feb 2012 .. am the original owner and have been a faithful customer of all maintenance & service bulletins to date.. I have a very good mechanic at the dealership but he told me the power steering pump was not under warranty and the cost would be $435 .. YIKES !! So I bought a pump from AutoZone and had it installed by a local mechanic .. now he's replaced it with yet another pump .. probably getting close to $200 in it and the problem has not been resolved. We called the dealership today and they told us we should have bought a GM pump / ?? something about it having 12 veins to accomodate the undersized/previous pump ?? .. will drive it as long as i can ??
 

·
Registered
Joined
·
252 Posts
B2B = bumper to bumper warranty, i.e. the first, short part of the warranty

As for the pump, I did hear that there was an updated pump. There is also a TSB on using Dexron-VI tranny fluid instead of power steering fluid.

I urge you to search the other forums like I suggested above for more information. There is a very long thread on the Traverse forum about this.
 

·
Registered
Joined
·
1,093 Posts
medicrxdoc said:
B2B = bumper to bumper warranty, i.e. the first, short part of the warranty

As for the pump, I did hear that there was an updated pump. There is also a TSB on using Dexron-VI tranny fluid instead of power steering fluid.

I urge you to search the other forums like I suggested above for more information. There is a very long thread on the Traverse forum about this.
Where is the TSB on using Dex-VI for PS fluid? I just got my PS pump and rack replaced and the color of the fluid is NOT bright pink, it is new fluid fluid but it is more of an amber color.
 

·
Registered
Joined
·
214 Posts
6Sixathome said:
Where is the TSB on using Dex-VI for PS fluid? I just got my PS pump and rack replaced and the color of the fluid is NOT bright pink, it is new fluid fluid but it is more of an amber color.
6Sixathome, here are two posts I found on the Traverse board from September and October talking about the TSB #P100294 for the power steering noise. I could not find a printed copy of the TSB, only the references in these posts. Hope it helps you.



October post @ Michelle & @ CGIM5804, the dealer had it for 36 hours. Replaced steering housing & return hose. Bleed lines and replaced PS fluid with Dexron 6 (ATF) per TB PI0029F. Noise is gone and happy with level of service provided. Let's hope this clears the noise up. Fingers crossed...



September post Sent in my 2010 Traverse for this problem and picked it up this morning.

Obviously, GM updated the TSB to #P10029F. This is what's written on the invoice.

CAUSE: CHECKED FOR BULLETINS, #P10029F RUBBING NOISE. NEEDS STEERING GEAR HOUSING, HOSE AND UPDATED FLUID
CORRECTION: INSTALLED GEAR HOUSING, HOSE AND RECOMMENDED FLUID, FLUSHED SYSTEM OF OLD FLUID. MAY TAKE THE TIME TO GET ALL TRAPPED AIR OUT. MUST SETTLE OVR NT.
 
1 - 11 of 11 Posts
Top