Saturn Outlook Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2009 saturn out look with 164k had a new engine put in about 2 years ago new engine only has 17k on it. Took my car in for a low tire pressure light and had to get a new tire pressure sensor. Ever sense i took it in for that i now have my traction control light coming on and seevice stabelrak. It also is reducing my engine power im looking for some help trying to figure out what is causing this to happen
 

·
Registered
Joined
·
215 Posts
There are plenty of posts on this subject, you can search for it on this and all of the Lambda Platform Forums, Traverse, Enclave and Acadia. This is a software generated message and there may be a dozen issues which can cause it. Easiest thing is check the brake fluid level, make sure its to line.
 

·
Registered
Joined
·
3 Posts
I have a 2009 saturn out look with 164k had a new engine put in about 2 years ago new engine only has 17k on it. Took my car in for a low tire pressure light and had to get a new tire pressure sensor. Ever sense i took it in for that i now have my traction control light coming on and seevice stabelrak. It also is reducing my engine power im looking for some help trying to figure out what is causing this to happen
Is it due for an oil change? Mine does that when the oil is dirty and stops after its changed
 

·
Registered
Joined
·
3 Posts
I have a 2009 saturn out look with 164k had a new engine put in about 2 years ago new engine only has 17k on it. Took my car in for a low tire pressure light and had to get a new tire pressure sensor. Ever sense i took it in for that i now have my traction control light coming on and seevice stabelrak. It also is reducing my engine power im looking for some help trying to figure out what is causing this to happen
Check for vacuum leaks ,dirty abs rings pressure wash behind tire could be throttle body get a good scan tool crook is bidirectional and 300 dollars on amazon
 
1 - 4 of 4 Posts
Top