Saturn Outlook Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
has anyone experience this? heres the story:

After I test drove the one i purchased on saturday, I told them i felt a vibration in the acceleration pedal when accelerating from a dead stop. I test drove another and it didn't feel the same. Well, i couldn't take the one I purchased home becasue it needed detailing and some prep work, and I wanted them to check out this vibration, so they gave a Outlook loaner. It accelerated pretty smooth. Well today they told me mine was ready for delivery and tried to sell me on the idea that the vibration was normal. I went to test it again, this time i acceletared slowly into second gear and thats when i felt the vibration. I told them they need to fix it and also the brakes seemed too mushy for a new car and they needed to look the brakes over too. the good thing is the salesmen agreed there was an issue. their game plan is to figure it out, if they can't. they'll get me me another one.

but i wanted to know if anyone else had this issue. i'd like to know how to get in touch with a saturn engineer about the problem.

I have never felt a vibration lkke this in any car I've ever owned. personnaly i think there's something wrong with the transmission.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #2
Update: After three days the service department is going to do the transmission recalibration that came out in May. This vehicle has not had it. I hope this fixes it.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
Followup 2: When I test drove my Outlook on Jul 26, the AC wasn't working. So as part of the Due Bill they serviced it. Well while it was in for the transmission recalibration, they had an AC problem still, so they changed the Compressor. I didn't get it back until Aug 4. well 2 days later, the AC went out again. Common sense was a leak. I took it in on Aug 8. They finally found a flex/rigid line going to the evaporator inside the cabin leaking. It took them 1.5 weeks to find this. The good thing is I had an Outlook loaner.

The when i got home, my trailer hitch cover was missing and a cover for the cargo net d-ringd was missing. had to bring it back in, they just canned parts off one in the lot.

The thing that amazed me was how many new Outlooks were still on the lot, when i was looking in July they had about 20, it looks like they have the same amount. The employee pricing is not working.
 
1 - 3 of 3 Posts
Top