Saturn Outlook Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
The rain is killing my Outlook. Thought I had survived all the recent rainfall because I haven't seen any leaks but I knew something was up/wet when rear wiper would not shut off with car running. After a couple of dry days it shut off. Rained again and yesterday my battery started showing a low charge and the DIC showed Service Battery Charging System. Opened the battery compartment to find battery wet and sitting in water. Waiting for some nice weather so that I can do some sealing. Just ain't happening...
 

·
Registered
Joined
·
27 Posts
Discussion Starter #3
Ya I'll do the tubes too. Right now I am stranded at work. Car died just as I got to work. The whole way the battery gauge was fluctuating from about 10 volts to 14 volts. Then it just kept going down and everything just shut down as I parked in my parking spot. See, things aren't so bad :eek:hno:

It starts but I don't know if it will get me home (20 minutes). Not sure if the wet battery is the culprit or the alternator or whatever is wet inside the car. I did seal the fixed sunroof today. I'll keep you posted on that one.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #4
Turned out to be the alternator. They wanted $500+ for new one. I opted for them to rebuild mine for half that price. I thought parts were cheaper when you bought American/Canadian made cars?

We've had some more rain and no leaks. Still plan on doing some more sealing under passenger side cowl just in case...
 

·
Registered
Joined
·
754 Posts
pricey indeed.
Your alternator post- is the 1st one I see/remember seeing on the Traverse, Acadia, Enclace, OUtlook forums.
 
1 - 5 of 5 Posts
Top