Saturn Outlook Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,093 Posts
Discussion Starter #1
Just wondering if anyone has had this done yet or if the dealer has'nt been able to get the heated washer fluid parts in. How about the sunroof recall, who's had that done? Does the fixed glass sunroof have drain tubes or is it sealed up tight like a windshield? Mine has had the drain tube extender's installed but still drips a whisper by the fuse block only when it decides that it wants to it's very strange because it does not do it all the time:banghead: Does anyone know of any place else that it could leak from? Could it be that water overwhelms the tray and drips over a little? How much water should be getting past the front sunroof seal and the roof? I've looked up in there when it was raining and saw some drips but nothing that would overwhelm the tray I dont think. I dont think that it is getting in through the cowl area the dealer's service department did some work on the cowl area under a bulliten. Any Lambda service techs out there with insight on where to look?
 

·
Registered
Joined
·
36 Posts
I had the wiper linkage recall done, it was a quick visit 45 min to a hour. When they were done I brang the car home and checked it, the cowl was not flush up against wind shield one of the clips was not in right , had to readjust it and push it in.They also pulled off the foam strips under the hood by the cowl I had to put them back on as they were just hanging there.
 

·
Registered
Joined
·
44 Posts
I just had these done this week, but no opportunity to try them since the weather has been decent. Based on the post above I'll have to see how the workmanship is.
 

·
Registered
Joined
·
46 Posts
BACK FROM THE DEAD!!!!

Just noticed that my wipers are slow as $h!t. I chalked it up to a hot day and only using the squirters.

Today it rains and pours and them puppies are S-L-O-W SLOW!!!

I hear through the grape vine that its a linkage thing. There was a recall maybe? I have an 07

Going to try a little dismantle and grease see what that gets me but wanted to post something to just get it out there and see if anyone else has run into this too?
 

·
Registered
Joined
·
161 Posts
delta88 said:
BACK FROM THE DEAD!!!!

Just noticed that my wipers are slow as $h!t. I chalked it up to a hot day and only using the squirters.

Today it rains and pours and them puppies are S-L-O-W SLOW!!!

I hear through the grape vine that its a linkage thing. There was a recall maybe? I have an 07

Going to try a little dismantle and grease see what that gets me but wanted to post something to just get it out there and see if anyone else has run into this too?

Mine were slow too. Greased them up and all is good. Also installed a new washer fluid heater too so I can have hot squirters again :blob: Got an extra new plug in ready heater if anyone wants one. Some how ordered 2 of them. :drunk:
 

·
Registered
Joined
·
396 Posts
poncho,

You might want to try and sell the heater on the Acadia forum; you would probably get more interest there :-\
 
1 - 7 of 7 Posts
Top